Вступление

Что такое реестр? Общая теория

Реестр - база данных операционной системы, содержащая конфигурационные сведения. Физически вся информация реестра разбита на несколько файлов. Реестры Windows 9х и NT частично различаются. В Windows 95/98 реестр содержится в двух файлах SYSTEM.DAT и USER.DAT, находящиеся в каталоге Windows. В Windows Me был добавлен еще один файл CLASSES.DAT.

По замыслу Microsoft он должен был полностью заменить файлы ini, которые были оставлены только для совместимости со старыми программами, ориентированными на более ранние версии операционной системы.

Почему произошел переход от ini файлов к реестру? Дело в том, что на эти файлы накладывается ряд серьезных ограничений, и главное из них состоит в том, что предельный размер такого файла составляет 64Кб.

ПРЕДУПРЕЖДЕНИЕ: НИКОГДА не удаляйте или не меняйте информацию в реестре, если Вы не уверены что это именно то, что нужно. В противном случае некорректное изменение данных может привести к сбоям в работе Windows и, в лучшем случае, информацию придется восстанавливать из резервной копии.


Редактор RegEdit и структура реестра

Основным средством для просмотра и редактирования записей реестра служит специализированная утилита "Редактор реестра". Для ее запуска наберите в запуске программы (Пуск->Выполнить) команду regedit.

Откроется окно программы, в которой слева отображается дерево реестра, похожее по виду на отображение структуры диска в Проводнике, а справа выводятся ключи, содержащиеся в выбранном (активном) разделе. С помощью редактора Вы можете редактировать значения, импортировать или экспортировать реестр, осуществлять поиск.

Рассмотрим подробнее структуру реестра. Реестр содержит шесть корневых разделов (ветвей), на которых ниже остановимся подробнее, каждый из них включает подразделы, отображаемые в левой части окна в виде значка папки. Конечным элементом дерева реестра являются ключи или параметры, делящиеся на три типа:

- строковые (напр. "C:\Windows");
- двоичные (напр. 10 82 A0 8F). Максимальная длина такого ключа 16Кб;
- DWORD. Этот тип ключа занимает 4 байта и отображается в шестнадцатеричном и в десятичном виде (напр. 0x00000020 (32) - в скобках указано десятичное значение ключа).

Давайте теперь рассмотрим корневые разделы, точнее какая информация в них содержится. Итак, начнем по порядку:

HKEY_CLASSES_ROOT. В этом разделе содержится информация о зарегистрированных в Windows типах файлов, что позволяет открывать их по двойному щелчку мыши, а также информация для OLE и операций drag-and-drop

HKEY_CURRENT_USER. Здесь содержатся настройки оболочки пользователя (например, Рабочего стола, меню "Пуск", ...), вошедшего в Windows. Они дублируют содержимое подраздела HKEY_USER\name, где name - имя пользователя, вошедшего в Windows. Если на компьютере работает один пользователь и используется обычный вход в Windows, то значения раздела берутся из подраздела HKEY_USERS\.DEFAULT

HKEY_LOCAL_MACHINE. Этот раздел содержит информацию, относящуюся к компьютеру: драйверы, установленное программное обеспечение и его настройки HKEY_USERS. Содержит настройки оболочки Windows для всех пользователей. Как было сказано выше, именно из этого раздела информация копируется в раздел HKEY_CURRENT_USER. Все изменения в HKCU (сокращенное название раздела HKEY_CURRENT_USER) автоматически переносятся в HKU

HKEY_CURRENT_CONFIG. В этом разделе содержится информация о конфигурации устройств Plug&Play и сведения о конфигурации компьютера с переменным составом аппаратных средств

HKEY_DYN_DATA. Здесь хранятся динамические данные о состоянии различных устройств, установленных на компьютере пользователя. Именно сведения этой ветви отображаются в окне "Свойства: Система" на вкладке "Устройства", вызываемого из Панели управления. Данные этого раздела изменяются самой операционной системой, так что редактировать что-либо вручную не рекомендуется.

Наибольший интерес представляют ветви HKEY_CURRENT_USER и HKEY_LOCAL_MACHINE. Именно там хранятся настройки, позволяющие привести Вашу операционную систему в надлежащий вид :).


Восстановление реестра

При работе с реестром надо соблюдать осторожность. Удаление каких-либо важных данных случайно или по незнанию может привести к краху операционной системы. Тогда спасти положение может только восстановление последней работоспособной копии.

Если Вы собрались поэкспериментировать с реестром, предварительно сохраните на диске файлы SYSTEM.DAT и USER.DAT. Они находятся в каталоге, куда была установлена операционная система и имеют атрибуты "только для чтения" и "скрытый". В случае если реестр будет серьезно испорчен, Вы сможете переписать эти файлы в каталог Windows, установить нужные атрибуты и реестр будет как новенький. Только не вздумайте восстанавливать эти файлы, когда загружен Windows, иначе система накроется окончательно и спасет ее только полная переустановка! Для восстановления этих файлов надо предварительно перезагрузиться в DOS и уже там заменять испорченные файлы хорошими.

Но это не единственный вариант восстановления данных. Дело в том, что операционная система, при каждом удачном запуске сохраняет копию реестра в CAB-файле, который записывается в скрытый каталог SYSBCKUP каталога Windows. По умолчанию, хранятся последние пять копий. Это число может варьироваться от 0 до 99 и устанавливается значением ключа MaxBackupCopies в файле scanreg.ini в каталоге Windows. Правда не стоит устанавливать слишком большое значение, т.к. файлы занимают немало места (один файл имеет размер больше мегабайта).

Чтобы восстановить реестр с одной из этих резервных копий надо перезагрузиться в DOS и выполнить команду

SCANREG /RESTORE

Появится список доступных резервных копий реестра отсортированных по времени их создания. После выбора нужной копии данные будут благополучно восстановлены, и Вы получите реестр, отвечающий состоянию дел на момент его создания.

Но если Вы устанавливали какие-то программы или меняли настройки операционной системы в промежуток между последней резервной копией и сбоем в реестре, то все эти данные безвозвратно пропадут. Надо ли нам это? Однозначно нет! Чтобы в любое время создать резервную копию реестра воспользуйтесь командой

SCANREG /BACKUP

которая в случае нормально прошедшей проверки создаст резервную копию.

Еще один вариант резервирования и восстановления реестра состоит в экспортировании раздела или целой ветви, которую Вы планируете изменять. Это можно осуществить в Regedite для Windows в меню "Реестр". Выделите нужный раздел и щелкните по пункту "Экспорт файла реестра". После задания имени файла данные этого раздела будут в него экспортированы. Файл имеет расширение REG. Для его импортирования в реестр достаточно дважды щелкнуть на нем и данные будут перенесены. Правда этот способ восстановления информации имеет один существенный недостаток: все удаленные или измененные записи будут восстановлены, но вот добавленные записи удалены не будут. Поэтому данный способ больше подходит, если Вы проводите какие-то несущественные изменения, и чтобы откатить их не вводя старые данные заново, можно воспользоваться экспортом/импортом.

Вообще, работать с реестром надо крайне осторожно, но если Вы будете периодически резервировать его, то никаких проблем возникнуть не должно.


Структура reg-файлов

Знание реестра Windows будет не полным без умения написать reg-файл. Начнем с того, что это такое. Reg-файл - это файл, имеющий определенную структуру и содержащий информацию, которая может быть импортирована в реестр. Если была заблокирована работа с редактором реестра , то наиболее легким способом подредактировать реестр будет создание и импортирование reg-файла (конечно, можно выйти в DOS, в защищенный режим, воспользоваться другими программами, но это все гораздо сложнее, а главное дольше).

К reg-файлам предъявляются определенные требования по структуре. Начнем с того, что в первой строке файла обязательно должно быть введено (для Windows 9x)

REGEDIT4

или (для Windows 2000/XP)
Windows Registry Editor Version 5.00

Обратите внимание на то, что буквы должны быть большие. Кроме этого в первой строке ничего быть не должно. После этого текста ОБЯЗАТЕЛЬНО должна быть пустая строка. Затем, указывается раздел реестра, в котором надо прописать или изменить какие-то параметры. Название раздела должно быть заключено в квадратные скобки [...]. Ниже прописываются параметры, которые надо добавить, по одному параметру в строке. Если вам надо провести изменения в нескольких разделах, то вы должны оставлять одну пустую строку между последним параметром предыдущего раздела и названием следующего раздела. Может немного запутанно, но вот как это должно выглядеть:

REGEDIT4

[Razdel1]
"param1"="znachenie1"
"param2"="znachenei2"
"param3"="znachenie3"

[Razdel2]
"param_1"="znachenie_1"

Последняя строка в файле должна быть ПУСТОЙ. После того, как вы создали такой файл, просто запустите его как обычную программу, вам будет выдан запрос о необходимости провести изменения в реестре, и после положительного ответа информация из файла будет импортирована. О результатах импортирования Windows сообщит в появившемся после этого окне.

Примечание: Windows 2000/XP обладает обратной совместимостью и может обрабатывать файлы, созданные в Windows 9x. Но если вы экспортировали файл в Windows XP и перенесли его на Windows 9x, то вручную измените первую строчку на REGEDIT4

Теперь пару слов о параметрах, которые можно добавлять. Как вы, наверное, обратили внимание, в приведенном выше примере добавляются параметры с помощью строк типа "param1"="znachenie1". Т.е. таким образом добавляется СТРОКОВЫЙ параметр с именем "param1" и значением "znachenie1". Но ведь существуют еще и параметры двоичные и DWORD. Формат записи для их добавления несколько другой. Для параметров типа DWORD используется строка

"param"=dword:XXXXXXXX

Здесь "param" - имя параметра, dword - указывает на тип этого параметра (буквы должны быть обязательно маленькие!) и после двоеточия следует значение из восьми цифр в шестнадцатеричном (!) формате. Однако большинство параметров DWORD имеют значение либо 0, либо 1, значит, вы должны написать соответственно либо 00000000, либо 00000001 вместо значков ХХХХХХХХ. Пробелы в строке не допускаются.

Для добавления двоичного параметра формат записи несколько иной:

"param"=hex:XX,XX,XX,....

Теперь расшифрую эту строку. Ну, с названием параметра все ясно, после знака "=" идет hex, т.е. указывается, что это будет двоичный параметр, затем идут шестнадцатеричные числа, отделенные запятой. Например, если вам надо добавить двоичный параметр равный "be 00 00 00", то вы пишете строку

"param"=hex:be,00,00,00

В реестре существуют параметры "По умолчанию" ("Default"). Чтобы присвоить им какое-то значение через reg-файл, надо добавить такую строку:

@="znachenie"

Здесь значок @ показывает, что у нас присваивается значение параметра "По умолчанию". Обратите внимание на то, что он не заключается в кавычки.

Теперь я приведу пример простенького reg-файла, который прописывает в реестр сайт, устанавливающий домашнюю страничку в Internet Explorer'e:

REGEDIT4

[HKEY_CURRENT_USER\Software\ Microsoft\Internet Explorer\Main]
"Start Page" = "http://winchanger.narod.ru/"

Удаление параметров

С помощью reg-файлов можно не только устанавливать новые параметры, но и удалять их. Например, для удаления раздела из реестра надо перед его именем в квадратных скобках поставить символ "-". Вот как это выглядит:

[-HKEY_LOCAL_MACHINE\Software\ QuickSoft\QuickStart]

Благодаря этой записи, подраздел "QuickStart" из раздела "QuickSoft" будет удален со всем содержимым.

Для удаления отдельных параметров используйте следующий синтаксис:

REGEDIT4

[HKEY_CURRENT_USER\Software]
"xxx"=-

Параметры командной строки

Редактор реестра можно запускать с некоторыми ключами

  • /s (импортирует значения из reg-файла без вывода диалогового окна)
  • /e (экспортирует параметры в reg-файл. Пример: regedit /e myfile.reg HKEY_USERS\.DEFAULT


Избранное

Избранное (Windows 98 и выше)

Удаление пункта Избранное

Если вы хотите удалить пункт Избранное из меню кнопки Пуск, то откройте раздел
HKEY_CURRENT_USER\ Software\Microsoft\Windows\CurrentVersion\ Policies\Explоrer и создайте параметр NoFavoritesMenu типа DWORD со значением, равным 1.

После перезагрузки пункт Избранное исчезнет из меню кнопки Пуск

Удаление параметра или установка в 0 возвращает пункт в меню


Документы

Удаление пункта Документы

Если вы хотите удалить пункт Документы из меню кнопки Пуск, то откройте раздел
HKEY_CURRENT_USER\ Software\Microsoft\Windows\CurrentVersion\ Policies\Explоrer и создайте параметр NoRecentDocsMenu типа DWORD со значением, равным 1.

После перезагрузки пункт Документы исчезнет из меню кнопки Пуск

Удаление параметра или установка в 0 возвращает пункт в меню

Управление количеством запоминаемых документов

Windows помнит список из 15 последних открытых документов, доступ к которому можно получить через Пуск-Документы. Если вы хотите изменить это значение по умолчанию, то то откройте раздел
HKEY_CURRENT_USER\ Software\Microsoft\Windows\CurrentVersion\ Policies\Explоrer и создайте параметр MaxRecentDocs типа DWORD со значением от 0x0 - 0xFFFFFFFF (0xF = 15 документам)).

Автоматическое очищение списка недавно открытых документов

Чтобы очищать список недавно открытых документов каждый раз при выключении компьютера, добавьте ключ ClearRecentDocsOnExit типа DWORD со значением 1.

Не запоминать открываемые документы

Если Вы хотите, чтобы открываемые Вами документы не запоминались в этом списке, надо добавить ключ NoRecentDocsHistory типа DWORD со значением 1.


Настройка

Скрытие пунктов подменю из меню Настройка

Если вы хотите скрыть пункты Панель управления, Принтеры, Удаленный доступ к сети и др. из меню Настройка, то откройте раздел
HKEY_CURRENT_USER\ Software\Microsoft\Windows\CurrentVersion\ Policies\Explоrer и создайте параметр NoSetFolder типа DWORD со значением, равным 1.

Установка этого ключа также удалит эти папки из окна "Мой компьютер"

Скрытие Панель задач и меню "Пуск" из меню Настройка

Если вы хотите скрыть пункт Панель задач и меню "Пуск" из меню Настройка, то откройте раздел
HKEY_CURRENT_USER\ Software\Microsoft\Windows\CurrentVersion\ Policies\Explоrer и создайте параметр NoSetTaskbar типа DWORD со значением, равным 1.

Скрытие Рабочий стол Active Desktop из меню Настройка (Windows 98)

Если вы хотите скрыть пункт Рабочий стол Active Desktop из меню Настройка, то откройте раздел
HKEY_CURRENT_USER\ Software\Microsoft\Windows\CurrentVersion\ Policies\Explоrer и создайте параметр NoSetActiveDesktop типа DWORD со значением, равным 1.

Все изменения вступают в силу после перезагрузки

Удаление параметра или установка в 0 возвращает скрытые пункты в меню Настройка


Поиск

Если вы хотите удалить пункт Поиск (Найти) из меню кнопки Пуск, то откройте раздел
HKEY_CURRENT_USER\ Software\Microsoft\Windows\CurrentVersion\ Policies\Explоrer и создайте параметр NoFind типа DWORD со значением, равным 1.

После перезагрузки пункт Поиск исчезнет из меню кнопки Пуск, а также исчезнет команда Найти из контекстного меню кнопки Пуск при нажатии на нее правой кнопкой. Также не будет работать клавиша F3, используемая для поиска. Кроме того, в Проводнике не будет работать кнопка Поиск (хотя сама кнопка будет на месте)

Удаление параметра или установка в 0 возвращает пункт в меню


Выполнить

Удаление пункта Выполнить из меню кнопки Пуск

Если вы хотите удалить пункт Выполнить из меню кнопки Пуск, то откройте раздел
HKEY_CURRENT_USER\ Software\Microsoft\Windows\CurrentVersion\ Policies\Explоrer и создайте параметр NoRun типа DWORD со значением, равным 1, - и пункт Выполнить исчезнет

Очистка списка недавно использованных команд

Команда Выполнить содержит список недавно использованных команд (MRU list)

Этот список содержится в разделе HKEY_CURRENT_USER\ Software\Microsoft\Windows\CurrentVersion\Explоrer\RunMRU.

Параметр MRUList содержит строку, определяющую порядок, в котором остальные записи будут появляться в списке. Например, запись "bca" говорит о том, что первым элементом в списке Открыть будет команда с именем b, потом c, а следом a

Сами команды хранятся как строки с оканчивающимися символами \1 в параметрах a, b, c, d и т.д. Всего допускается 26 записей

Для очистки списка нужно заменить параметры MRUList и все команды пустой строкой (""), либо отредактируйте по своему вкусу

Изменения вступят в силу после перезагрузки


Завершение работы

Выключить компьютер можно двумя способами

  • Используя команду Завершение работы меню кнопки Пуск
  • Открывая окно Завершение работы программы нажатием кнопок Ctrl+Alt+Del и нажимая кнопку Завершить работу
Windows позволяет запретить выключение этими способами для текущего пользователя

Для этого откройте раздел
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer и создайте параметр NoClose типа DWORD со значением, равным 1.

Кнопка Завершить работу в окне Завершение работы программы станет недоступной сразу же после изменения в реестре. После перезагрузки пункт Завершение работы исчезнет из меню кнопки Пуск

Удаление параметра или установка в 0 возвращает пункт в меню

Это относится только к стандартным средствам Windows. Специальные программы или утилиты по-прежнему могут выключать компьютер


Завершение сеанса

Завершение сеанса (Windows 98 и выше)

Удаление пункта Завершение сеанса из меню кнопки Пуск

Если вы хотите удалить пункт Завершение сеанса из меню кнопки Пуск, то откройте раздел
HKEY_CURRENT_USER\ Software\Microsoft\Windows\CurrentVersion\ Policies\Explоrer и создайте параметр NoLogOff типа DWORD со значением, равным 01 00 00 00, - и пункт Завершение сеанса исчезнет

Изменения вступят в силу после перезагрузки

Удаление параметра или установка его в 00 00 00 00 возвращает команду


Запрещение использования сеансов MS-DOS и однозадачного режима MS-DOS

Запрещение использования сеансов MS-DOS и однозадачного режима MS-DOS (Windows 98)

Windows позволяет открывать окно MS-DOS и выполнять старые приложения MS-DOS. Эта команда доступна в подменю Программы меню Пуск. Для запрета использования сеансов MS-DOS откройте (создайте) раздел
HKEY_CURRENT_USER\ Software\Microsoft\Windows\CurrentVersion\Policies\WinOldApp и создайте параметр Disabled типа DWORD со значением, равным 0x00000001.

Однозадачный режим MS-DOS доступен через переключатель перезагрузить в режиме MS-DOS в диалоге Завершение работы Windows, который появляется при выборе пункта Завершение работы в меню Пуск. Для запрета использования однозадачного режима MS-DOS откройте (создайте) раздел
HKEY_CURRENT_USER\ Software\Microsoft\Windows\CurrentVersion\Policies\WinOldApp и создайте параметр NoRealMode типа DWORD со значением, равным 0x00000001.

После перезагрузки установки вступят в силу

Удаление параметра или установка в 0 возвращает прежнее поведение

Имейте в виду, что можно перезагрузив компьютер и выбрав альтернативную загрузку или используя загрузочный диск, войти в режим MS-DOS


Контекстное меню кнопки Пуск

Если вы хотите запретить контекстное меню кнопки Пуск, позволяющее удалять, переименовывать и т.д., а также возможность перемещения пунктов меню методом drag-n-drop, то откройте раздел
HKEY_CURRENT_USER\ Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer и создайте параметр NoChangeStartMenu типа DWORD со значением, равным 1.

После перезагрузки установки вступят в силу

Удаление параметра или установка в 0 возвращает прежнее поведение


Мои документы

Когда вы подводите курсор к значку Мои документы на Рабочем столе, то появляется всплывающая подсказка. Для ее изменения используйте строковый параметр HKEY_CLASSES_ROOT\CLSID\{450D8FBA-AD25-11D0-98A8-0800361B1103}\InfoTip, в которой укажите желаемую строку (например, "Здесь хранятся секретные материалы")


Корзина

Всплывающая подсказка

Когда вы подводите курсор к значку Корзина на Рабочем столе, то появляется всплывающая подсказка. Например, в Windows Me содержится надпись следующего содержания: "Используется для временного хранения удаленных файлов, пока они не будут окончательно стерты". Для изменения этой надписи используйте строковый параметр HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\InfoTip, в которой укажите желаемую строку (например, "Здесь хранится мусор")

Новое имя для корзины

В отличие от многих других элементов на Рабочем столе, у Корзины нет команды Переименовать. А иногда так хочется! Ищем раздел HKEY_CURRENT_USER\SOFTWARE\CLSID\{645FF040-5081-101B-9F08-00AA002F954E} и меняем строковый параметр (По умолчанию). Например, пишем Свалка. Обновите Рабочий стол, чтобы изменение вступило в силу


Обои для Рабочего стола

За картинку, используемую в качестве обоев для Рабочего стола отвечает строковый параметр
HKEY_CURRENT_USER\Control Panel\Desktop\Wallpaper, который содержит путь bmp-файла


Контекстное меню Проводника

Чтобы сделать недоступным контекстное меню Проводника при щелчке правой кнопкой мыши, найдите ветвь:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion \Policies\Explorer
- и создайте параметр NoViewContextMenu типа DWORD со значением 1


Замена фона в панели инструментов в Проводнике

Существует возможность установки своего фона для панели инструментов в Проводнике. Для этого в разделе реестра HKEY_CURRENT_USER \SOFTWARE\ Microsoft\Internet Explorer\Toolbar создайте строковый параметр BackBitmapShell, значением которого будет полное имя BMP-файла с нужной картинкой - она и замостится мозаикой на панелях окон.

Для замены фона не только в Проводнике, но и в Internet Explorer смотрите Замена фона в панели инструментов в Internet Explorer


Установка классического вида

Установка классического вида в Проводнике (Windows 98 и выше)

Проводник Windows содержит пункты меню, как Переход и Избранное, которые отражают новые Web-возможности Windows. Если нет необходимости использовать новые возможности, то можно использовать классический стиль окон оболочки и проводника, добавив параметр ClassicShell со значением DWORD равным 0x00000001 в раздел HKEY_CURRENT_USER\SOFTFARE\Microsoft\Windows\CurrentVersion\Policies\Explorer


Удаление вкладки DFS

Удаление вкладки DFS (Windows 2000/XP)

Чтобы удалить вкладку DFS из проводника, что позволит предотвратить изменение свойств локальных сетевых ресурсов DFS пользователями, выполните следующее:
Перейдите в подраздел HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\PoliciesExplorer и создайте ключ типа DWORD NoDFSTab со значением равным 1


Установка и удаление программ

Установка и удаление программ (Windows NT/2000/XP)

Скрытие апплета Установка и удаление программ

Чтобы пользователь не мог воспользоваться апплетом Панели управления Установка и удаление программ, создайте в разделе HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall ключ NoAddRemovePrograms типа DWORD и установите его равным 1

Теперь, если пользователь выберет пункт Установка и удаление программ в Панели управления, то будет показано сообщение об ошибке

Изменение или удаление программ

Чтобы скрыть вкладку Изменение или удаление программ в апплете Установка и удаление программ, создайте в разделе HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall ключ NoRemovePage типа DWORD и установите его равным 1

Установка программ

Чтобы скрыть вкладку Установка программ в апплете Установка и удаление программ, создайте в разделе HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall ключ NoAddPage типа DWORD и установите его равным 1

Установка компонентов Windows

Чтобы скрыть вкладку Установка компонентов Windows, создайте в разделе HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall ключ NoWindowsSetupPage типа DWORD и установите его равным 1

CD или дискета

Чтобы скрыть раздел Установка программы с CD-ROM или дискеты и кнопку CD или дискета на вкладке Установка программ, создайте в разделе HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall ключ NoAddFromCDorFloppy типа DWORD и установите его равным 1

Windows Update

Чтобы скрыть раздел Установка программы от Майкрософт и кнопку Windows Update на вкладке Установка программ, создайте в разделе HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall ключ NoAddFromInternet типа DWORD и установите его равным 1

Сведения о поддержке

Некоторые программы, представленные в списке Изменение или удаление программ могут содержать ссылку Чтобы получить сведения о поддержке, щелкните здесь. Чтобы скрыть данную ссылку, создайте в разделе HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall ключ NoSupportInfo типа DWORD и установите его равным 1

Список установленных программ

Иногда в списке установленных программ Изменение или удаление программ может содержаться мусор (неправильно удаленные программы). Некоторых очень раздражают эти записи программ, которых давно уже нет на компьютере. Чтобы очистить этот список, найдите раздел HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall, который содержит подразделы, отвечающие за каждый отдельный продукт. Просто удалите ненужные подразделы

Информация о продукте

Можно настроить внешний вид записи в разделе Установленные программы и диалогового окна Поддержка, которое появляется при щелчке на ссылке Чтобы получить сведения о поддержке, щелкните здесь.
Для включения нужного режима используйте строковые значения в разделе HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\<имя программы>

  • DisplayIcon - иконка, соответствующая приложению в диалоге "Установка и удаление программ"
  • DisplayName - Описание приложения
  • ModifyPath - Путь инсталлятора (утилиты) для изменения установочных параметров программы. Еcли этот ключ установлен, то Кнопка "Заменить/Удалить" распадается на две - "Заменить" (Выполняется ModifyPath) и "Удалить" (выполняется UninstallString)
  • UninstallString - путь деинсталлятора
Ключи для диалогового окна Поддержка

Если вы создадите параметр Publisher, то в описании удаляемой программы появляется ссылка Чтобы получить сведения о поддержке, щелкните здесь, которая открывает диалоговое окно Поддержка. Для настройки внешнего вида этого окна используйте следующие строковые значения

  • Publisher - Издатель продукта
  • Readme - Путь к файлу Readme для данного продукта
  • Comments - Коментарии к продукту
  • Contact - Контактное лицо (e-mail и т.п.)
  • DisplayVersion - Номер версии
  • ProductID - Код продукта
  • RegCompany - Зарегистрированная компания
  • RegOwner - Зарегестрированный владелец
  • URLInfoAbout - Домашняя страничка производителя (параметр Publisher становится ссылкой)
  • URLUpdateInfo - URL обновления продукта
  • HelpLink - URL сведений о поддержке


Свойства папки

Если вы хотите удалить пункт Свойства папки из меню Проводника, а также из Панели управления, то откройте раздел
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer и создайте параметр NoFolderOptions типа DWORD со значением, равным 1.

После перезагрузки пункт Свойства папки исчезнет из меню Проводника и из Панели управления

Удаление параметра или установка в 0 возвращает пункт в меню и в Панель управления

Примечание: В Windows 98 Свойства папки находились не на Панели управления, а в меню Настройка кнопки Пуск


Регистрационный номер

Регистрационный номер (Windows 95/98/Me)

Если вы потеряли свой регистрационный номер от компакт-диска с Windows, то не сможете переустанавливать систему. Но реестр поможет нам!

Для этого найдите ветвь:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion
и найдите строковое значение ProductKey, который и содержит ваш регистрационный номер


Регистрационные данные

Если вы нажмете на кнопку О программе в Проводнике или в других программах, поставляемых с Windows, то увидите, кто обладает правом использования этой копии. Также эти данные можно увидеть в апплете Система Панели управления. Возможно, вам компьютер достался от вашего босса Пупкина, и вы страстно хотели бы изменить регистрационные данные. Я помогу вам.

Для Windows 95/98/Me: Откройте раздел HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion и изменяйте строковые параметры RegisteredOwner (Ваше имя) и RegisteredOrganization (название организации)

Для Windows NT/2000/XP: Название раздела чуть-чуть другое - HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion


Что скрывается в автозагрузке?

Существует несколько способов прописать программу в автрозагрузку. Самый простой - скопировать программу или ярлык в папку Автозагрузка. Например, у меня прописан там AVP Монитор. Но существует другой способ - через реестр. Этим способом часто пользуются вредоносные программы (вирусы, трояны, шпионы)

Сперва откройте раздел
HKEY_LOCAL_MACHINE\Software\ Microsoft\Windows\CurrentVersion.

Найдите там подразделы Run, RunOnce, RunOnceEx, RunServices, RunServicesOnce. В этих разделах есть строковые ключи (некоторые разделы пустые), отвечающие за запуск программ. Название ключа может быть произвольным, а в качестве значения у них указывается запускаемая программа, если надо - то с параметрами. Обратите внимание на разделы, в названии которых присутствует "Once". Это разделы, в которых прописываются программы, запуск которых надо произвести всего один раз. Например, при установке новых программ некоторые из них прописывают туда ключи, указывающие на какие-нибудь настроечные модули, которые запускаются сразу после перезагрузки компьютера. Такие ключи после своего запуска автоматически удаляются.

Внимательно проверьте, что за программы у вас запускаются. Сразу после установки Windows в разделе Run присутствуют ключи с названиями internat.exe, LoadPowerProfile, ScanRegistry, SystemTray, TaskMonitor. В разделе RunServices - ключ LoadPowerProfile. Другие разделы пустые. Остальные ключи, которые могут присутствовать у вас в реестре, были добавлены другими установленными программами. Подумайте, все ли они нужны вам при загрузке и лишнее просто удалите. Это позволит значительно ускорить загрузку Windows.

Но это не единственный раздел, откуда запускаются программы. Перейдем к другой ветви, а именно к
HKEY_CURRENT_USER и откроем там раздел SOFTWARE\Microsoft\Windows\CurrentVersion. Там есть только два подраздела, отвечающие за автозагрузку: Run и Runonce. Изначально они пустые, так что все записи там сделаны другими программами.

Для операционных систем Windows 9x возможно загружать программу с помощью драйвера VxD. Полный список загружаемых драйверов находится в разделе HKEY_LOCAL_MACHINE\System\ CurrentControlSet\Services\VxD. В Windows NT/2000 нет VxD драйверов, но в разделе HKEY_LOCAL_MACHINE\System\ CurrentControlSet\Control\SessionManager в параметре BootExecute можно прописать программу, которая будет грузиться еще до загрузки графической оболочки и сервисов.


Контекстное панели задач

Контекстное меню панели задач

Если вы хотите запретить контекстное меню панели задач, то откройте раздел
HKEY_CURRENT_USER\ Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer и создайте параметр NoTrayContextMenu типа DWORD со значением, равным 1.

После перезагрузки установки вступят в силу

Удаление параметра или установка в 0 возвращает прежнее поведение


Диалоговое окно открытия и сохранения файла

Windows Me/2000 имеет новое диалоговое окно "Открыть\Сохранить файл", которое можно изменить по Вашему желанию.

В левой части диалогового окна расположены пять системных папок, которые можно поменять местами или изменить на те, которыми вы часто пользуетесь. Создайте в ветви:
[HKEY_USERS\.DEFAULT\SOFTWARE\Microsoft\ Windows\CurrentVersion\Policies\comdlg32]
раздел "PlacesBar". В нем хранятся имена папок. Как я уже говорил, их пять. И у каждой свой параметр. У первой "Place0", у второй "Place1", а у пятой "Place4". Системные папки имеют значение типа DWORD:
Название папки | Значение
Рабочий стол | 00000000
Мои документы | 00000005
Мои рисунки | 00000027
Мои видеозаписи | 0000000e
Мой компьютер | 00000011
Избранное | 00000006
Мое сетевое окружение | 00000012
Шрифты | 00000014
History | 00000022

Папки могут быть и обычные, где строковое значение параметра Place указывает путь к папке. Например:
"Place0"="C:\Windows"
"Place1"="C:\Windows\Systems"

Если вы не используете все пять параметров, а только часть из них, например Place0 и Place1, то в левой части диалогового окна будут отображаться столько же папок.

Старый вид диалогового окна

Чтобы вернуться к старому виду диалогового окна Windows 95/98, создайте строковый параметр NoPlacesBar со значением 1 (или любым другим) в [HKEY_USERS\.DEFAULT\SOFTWARE\Microsoft\ Windows\CurrentVersion\Policies\comdlg32]

Убираем кнопку Назад

Чтобы убрать кнопку Назад из Общего диалогового окна, создайте параметр NoBackButton типа DWORD в [HKEY_USERS\.DEFAULT\SOFTWARE\Microsoft\ Windows\CurrentVersion\Policies\comdlg32] со значением 1

Убираем список файлов

Чтобы убрать выпадающее комбинированное окно со списком файлов (Имя файла), создайте параметр NoFileMru типа DWORD в [HKEY_USERS\.DEFAULT\SOFTWARE\Microsoft\ Windows\CurrentVersion\Policies\comdlg32] со значением 1


Добавление нового пункта в меню "Создать"

Пункт контекстного меню "Создать" появляется, если щелкнуть на Рабочем столе или в Проводнике на свободном месте открытой папки. Существует возможность добавления нового пункта в это меню. Например, если вы веб-дизайнер, то было бы удобно иметь пункт Документ HTML, который позволит вам сразу создать заготовку для вашей странички.

Разобъем работу на несколько этапов. Для начала найдем каталог ShellNew в папке Windows. Там хранятся заготовки для файлов, которые создаются с помощью контекстного меню. Например, если у вас установлен Microsoft Office, то вы увидите в этом каталоге файлы-заготовки для Word и Exce.

Следующий шаг - создайте в папке файл, например index.html. Внутри него напишите шаблон вашей странички. Например, так:

<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=windows-1251">
<title>Мой заголовок</title>
</head>
<body>

</body>
</html>

Третий этап. Работаем с реестром. Итак, ищем раздел HKEY_CLASSES_ROOT\.html и создаем раздел ShellNew. В этом разделе создаем строковый параметр FileName в качестве значения которого надо указать имя созданного нами шаблона (index.html). После перезагрузки в контекстном меню появится новый пункт.

Существуют и другие способы. Можно не создавать шаблон файла. Он может быть и пустым, но тогда вместо параметра FileName надо создать пустой строковый параметр NullFile.


Контекстное меню папок и файлов

При установке многих программ контекстное меню файлов и папок постепенно заполняется лишними пунктами.

Чтобы оставить в меню только то, что действительно нужно, найдите ветвь:
HKEY_CLASSES_ROOT\*\ shellex\ContextMenuHandlers
- в ней в качестве подразделов выступают команды, отображаемые в меню любого файла. Просто удалите то, то вам не нужно.

Команды, привязанные к конкретному типу файлов можно найти уже в ветвях, соответствующих такому типу. Например, для файла AVI это будет раздел
HKEY_CLASSES_ROOT\ avifile\ shell.

За меню папок же отвечают
HKEY_CLASSES_ROOT\ Directory\shell и HKEY_CLASSES_ROOT\ Folder\shell


Увеличение скорости всплывания меню

Иногда при выборе меню появляется подменю.Существует возможность менять скорость появления этих подменю (в т.ч. меню кнопки Пуск), облегчая работу на компьютере. Для этого используйте строковый параметр MenuShowDelay в разделе HKEY_CURRENT_USER\Control Panel\Desktop.

По умолчанию он равен "400". Значение "0" соответствует наиболее быстрому реагированию на движение мыши. В Windows 95 значение параметра можно изменять в диапазоне от 1 до 10. В последующих версиях Windows данный параметр можно менять от "0" до "32767" и от "-32768" до "-2"

Сделанные изменения вступят в силу после перезагрузки


Запрещение запуска программ

Windows позволяет ограничить доступ к программам, кроме разрешенных в специальном списке.

Для ограничения запускаемых программ надо открыть раздел HKEY_CURRENT_USER\SOFTWARE\Microsoft\ Windows\CurrentVerson\Policies\Explorer и создать там ключ RestrictRun типа DWORD со значением 0х00000001. Затем тут же надо создать подраздел с аналогичным именем RestrictRun и в нем перечислить список РАЗРЕШЕННЫХ к запуску программ для текущего пользователя. Записи в этом подразделе пронумеровываются, начиная с 1, и содержат строки с путями (необязательно) и именами приложений. Файлы должны быть с расширением. Например, Word.exe, Excel.exe ...

Не забудьте указать файл Regedit.exe, иначе Вы сами не сможете больше запустить редактор реестра! Для сброса ограничения на запуск программ надо установить значение ключа RestrictRun в 0


Запрещение запуска редактора реестра

Вы можете запретить запуск редактор реестра

Для этого в разделе HKEY_CURRENT_USER\SOFTWARE\Microsoft\ Windows\CurrentVerson\Policies\System нужно добавить ключ DisableRegistryTools со значением 0х00000001 типа DWORD. Запуск редактора реестра будет запрещен, однако останется возможность вносит изменения с помощью программного обеспечения сторонних разработчиков и с помощью REG-файла


Запрет на режим командной строки и обработки bat-файлов

Запрет на режим командной строки и обработки bat-файлов (Windows 2000/XP)

Существует возможность запрета на режим командной строки (cmd.exe) и обработки bat-файлов. Для этого найдите или создайте параметр типа DWORD DisableCMD в разделе HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\System.

Данный параметр может принимать следующие значения
0 (или отсутствие записи в реестре | Система может использовать режим командной строки и обрабатывать bat-файлы
1 | Система не может использовать режим командной строки, но может обрабатывать bat-файлы
2 | Система не может использовать режим командной строки и обрабатывать bat-файлы

Сделанные изменения вступают в силу немедленно


Консольные команды Windows

Консольные команды Windows 2000/XP

Запрет на расширенный режим командного процессора (cmd.exe))

Существует возможность запрета на расширенный режим командного процессора (cmd.exe). Например, в расширенном режиме существуют такие команды как del, erase, chdir, goto. Для запрета найдите или создайте параметр типа DWORD EnableExtensions в разделе HKEY_CURRENT_USER\Software\Microsoft\Command Processor и присвойте ему значение 0. Для включения этого режима используйте значение 1

Также имеется аналогичная запись в разделе HKEY_LOCAL_MACHINE\Software\Microsoft\Command Processor

Отложенное расширение переменных среды

Отложенное расширение переменных среды по умолчанию не включено. Для включения используйте параметр типа DWORD DelayedExpansion в разделе HKEY_CURRENT_USER\Software\Microsoft\Command Processor, равный 1 (Аналогичная запись в ветви HKEY_LOCAL_MACHINE)


Защита системных файлов

В Windows Me на смену утилите sfc.exe пришла автоматически отслеживающая замену файлов служба System File Protection, которая не только обнаружит попытку переписать важный файл, но и сама восстановит его исходный вариант. Защита системных фалов — это средство Windows, обеспечивающее сохранность файлов, необходимых для работы системы. Оно предотвращает замену этих файлов их старыми версиями и версиями, не утвержденными корпорацией Майкрософт. Даже приложения, разработанные корпорацией Майкрософт, не могут заменять защищенные этой системой файлы на их старые версии. Приложения сторонних поставщиков могут заменять системные файлы, только если эти файлы поставляются с каталогом, подписанным корпорацией Майкрософт, содержащим более новый файл.

Если вы ее не отключали всяческими "твикерами" (что крайне не желательно делать), то программа работает неплохо, в чем вы можете сами убедиться, включив выдачу сообщений о ее действиях - по умолчанию эта система никак о себе не заявляет. Если хотите получать каждый раз уведомление о срабатывании системы глобальной защиты основных файлов, то установите такой параметр в реестре:
HKEY_LOCAL_MACHINE\Software\Microsoft\ Windows\CurrentVersion\SystemFileProtection ShowPopups=dword:00000001

А почитать протокол уже проделанной работы System File Protection можно в файле C:\Windows\System\Sfp\sfplog.txt. При этом "родные" файлы для замены она берет не с компакт-диска, а из папки C:\Windows\Options, в которую записывает и обновленные после посещения Windows Update библиотеки, так что файлы в ее базе всегда самые свежие и удалять эту папку я тоже не советую.


Разрешение на использование файла "autorun.inf"

Разрешение на использование файла "autorun.inf" (Windows Me)

В Windows существует возможность изменения значка дисков и автозапуска программ при помощи файла "autorun.inf".

Но в Windows Me, если вы захотите таким образом изменить значки логических дисков, этот прием не сработает. Дело в том, что существует ключ, разрешающий использовать файлы "autorun.inf". Итак, найдите ветвь:
HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MountPoints\C. Теперь для разрешения считывать информацию из файла "autorun.inf" на диске "С:", нужно создать строковой параметр _HasNotif с пустой строкой (""). Если у Вас есть еще логические диски "D:, E:" и т.д., то создайте для них тот же параметр _HasNotif="" в:
HKEY_CURRENT_USER\SOFTWARE\Microsoft\ Windows\CurrentVersion\Explorer\MountPoints\D и по аналогии - для всех оставшихся дисков.


Cистемное время

Windows XP умеет подстраивать системное время, сверяясь со специальными серверами в интернете. Можно изменить адреса используемых серверов.

Без использования реестра: Щелкните правой кнопкой мыши на значке часов в системной области панели задач, выберите команду "Adjust Date/Time" и на странице "Internet Time" установите нужный сервер

При помощи реестра: Откройте раздел
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ Windows\CurrentVersion\DateTime\Servers
внесите свой собственный список серверов, использующихся для синхронизации времени.


Изменение порога выдачи предупреждения о недостатке свободного места на диске (Windows NT/2000/XP)

Если на вашем диске остается свободным менее 10% (по умолчанию) места, то система информирует об этом появлением иконки в области уведомления (рядом с часиками). На дисках маленькой емкости этот порог вполне оправдан, но для дисков большой емкости (20 Гбайт -> 2 Гбайт) это не совсем удобно. Можно изменить порог в процентном соотношении:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services\LanmanServer\Parameters - параметр типа DWORD DiskSpaceThreshold, в котором указываете значение от 0 до 99 (т.е процент от объема диска)

Недостаточно места на диске

Если Windows постоянно выводит сообщения о том, что на диске мало места (см. выше), то в разделе реестра
HKEY_CURRENT_USER\ Software\Microsoft\Windows\CurrentVersion\ Policies\Explоrer создайте параметр NoLowDiskSpaceChecks типа DWORD со значением, равным 1, - и Windows заткнется :-)


Управление размером блока данных при фрагментации

Как уменьшить фрагментируемость больших файлов на диске?

Для того чтобы операционная система при записи файла на диск сначала нашла для него наиболее подходящее по размеру место и поместила его туда, как можно меньше дробя на части, необходимо добавить в реестр:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem параметр ContigFileAllocSize со значением типа dword равный 00000200, который и определяет максимальный размер нефрагментируемого блока данных на диске. При желании размер такого блока можно еще увеличить. Данная настройка может быть очень полезной при работе с мультимедиа (уменьшается нагрузка на диск и процессор при записи и воспроизведении видео или звуковых файлов).


ScanDisk

ScanDisk (для Windows Me)

При неправильном выключении компьютера при последующей загрузке ОС запускается ScanDisk, но в нем установлен флажок "Автоматически исправлять ошибки", причем флажок этот затемнен, и снять его невозможно. В результате приходится вообще отключать эту проверку, иначе высок риск неверных изменений таблицы FAT - пользователь не может контролировать процесс исправления каждой ошибки!

Чтобы отключить автоисправления, найдите следующий ключ:
HKEY_USERS\.DEFAULT\SOFTWARE\Microsoft\ Windows\CurrentVersion\Applets\Check Drive
и установите следующий параметр:
AutoChk = 02 00 00 00

Для возврата автоматического режима ставьте
AutoChk = 00 00 00 00


Num Lock

Num Lock (Windows 2000/XP)

Некоторые сетуют, что при входе пользователя в систему переключатель клавиатуры Num Lock всегда выключен. Можно ли сделать, чтобы он всегда был включен?

Для этого найдите ветвь:
HKEY_CURRENT_USER\Сontrol Panel\Keyboard
и установите строковое значение InitialKeyboardIndicators равным "2"


Отключение клавиши Windows

На некоторых современных клавиатурах присутствует клавиша Windows (как правило, логотип-флажок Майкрософт). Некоторым пользователям она мешает при быстрой печати. Чтобы отключить ее, нужно в реестре найти ключ
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout. Создайте новый двоичный параметр, озаглавив его Scancode Map и присвойте ему значение 00 00 00 00 00 00 00 00 03 00 00 00 00 00 5B E0 00 00 5C E0 00 00 00 00.
После перезагрузки клавиша Windows будет отключена.


Создание псевдонима для программы

Существует скрытая возможность создания псевдонима для запускаемой программ. Например, вы выбрали команду Пуск-Выполнить и напечатали WINRAR, а запускается блокнот NOTEPAD

Для этого найдите ветвь:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths
- в ней в качестве подразделов выступают имена программ.

Войдите в один из разделов, например WINRAR.EXE из измените строковое значение по умолчанию на путь к другой программер, например C:\WINDOWS\NOTEPAD.EXE.

Теперь закройте реестр. Выберите Пуск-Выполнить и напечатайте winrar и у вас запустится блокнот


Размер реестра

Размер реестра (Windows NT/2000)

Размер реестра ограничивается параметром RegistrySizeLimit (тип REG_DWORD) в разделе реестра HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control.

Увеличить максимальное значение его объема можно и в окне "Virtual Memory" диалога System Properties > Advanced > Performance Options > Change


Отключение дебаггера

Отключение дебаггера (Windows NT/2000/XP)

При возникновении каких-либо неполадок в работе приложений пользователю показывается окно с сообщением об ошибке и предложением закрыть приложение, при этом DrWatson (дебаггер по умолчанию) автоматически записывает информацию о сбое в log-файл. Для отключения этой службы вставляем в ключ реестра HKEY_LOCAL_MACHINE\ SOFTWARE\Microsoft\ Windows NT\Current Version\AeDebug строковый параметр Auto со значением 0. После этого DrWatson больше не будет загружаться автоматически, а будет выводится окно с сообщением об ошибке. По умолчанию установлен 0 (автоматическая загрузка дебаггера)


Зависшие программы

Зависшие программы (Windows NT/2000/XP)

Время, по истечении которого программу считать зависшей

Иногда программа зависает, т.е. не реагирует на обращение к ней. Приходится принудительно закрывать его (например, через Диспетчер задач (Ctr-Shift-Esc)):
Ключ HungAppTimeout в разделе HKEY_CURRENT_USER\Control Panel\Desktop определяет время, по прошествии которого не отвечающее приложение считается зависшим (по умолчанию 5000 миллисекунд). Измените данный строковый параметр на необходимое значение

Время ожидания перед завершением зависшего приложения

Ключ WaitToKillAppTimeout в разделе HKEY_CURRENT_USER\Control Panel\Desktop задает время ожидания перед завершением зависшего приложения (по умолчанию 2000 миллисекунд). Измените данный строковый параметр на необходимое значение

Автоматическое завершение зависших программ

Вы можете разрешить системе автоматически завершать зависшие процессы. Для этого используйте строковый параметр AutoEndTasks в разделе HKEY_CURRENT_USER\Control Panel\Desktop
Значение "1" разрешает системе автоматически завершать процессы
Значение "2" - процессы не завершаются автоматически. Система ожидает, когда процесс завершится, и если время завершения процесса превышаетзначение HungAppTimeout (см. выше), то появлятеся диалоговое окно Завершение работы, указывающее, что приложение зависло

Примечания

При установке слишком малых значений в указанных ключах могут возникнуть проблемы с автозавершением запущенных задач, так как приложение может длительное время не отвечать на запросы в случае достаточно большой загруженности процессора или работой с другими программами


Формат MS-DOS для файлов и папок

Формат MS-DOS для файлов и папок (Windows NT/2000/XP)

По умолчанию Windows NT и выше создают в разделе NTFS специальную таблицу, содержащую все имена файлов и папок в формате MS-DOS по формуле 8.3 (8 символов имени файла и 3 символа для его расширения). Данная возможность в настоящее время не совсем актуальна и ее можно отключить для повышения производительности системы

Для этого установите параметр типа DWORD NtfsDisable8dot3NameCreation в разделе
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem равным 1

Установки вступят в силу после перезагрузки системы


Обновление метки последнего доступа к папке

Обновление метки последнего доступа к папке (Windows NT/2000/XP)

По умолчанию Windows NT и выше в системе NTFS обновляют метку последнего доступа к папке при их открытии. Данная возможность может тормозить вашу систему при слишком большом количестве папок. Если вас не интересует данная метка, то можете отключить данную возможность.

Для этого установите параметр типа DWORD NtfsDisableLastAccessUpdate в разделе
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem равным 1

Установки вступят в силу после перезагрузки системы


Быстрое завершение работы Windows

Быстрое завершение работы Windows (Windows NT/2000/XP)

Windows NT версии 3.1и 3.5 позволяла закрыть все процессы за 20 секунд. В Windows NT 3.51 и выше существует возможность определять величину интервала, в течение которого система должна завершить свою работу. Для этого необходимо исправить ключ системного реестра – строковый параметр WaitToKillServiceTimeout, где установлена временная задержка закрытия всех запущенных сервисов в миллисекундах.

Этот ключ расположен в разделе HKEY_LOCAL_MACHINE/SYSTEM/ CurrentControlSet/Control

По умолчанию значение параметра равно 20000, что эквивалентно 20 секундам.

Для уменьшения времени завершения, нужно уменьшить это значение, например до 1000, что эквивалентно 1 секунде. Однако, помните, что слишком значительное уменьшение значения этого ключа не позволит системе корректно завершить запущенные сервисы, что может сказаться на стабильности загрузки. Во время завершения работы, система уведомляет все сервисы и дает каждому сервису время на корректное закрытие. По истечении этого времени система уничтожает сервис. При этом некоторые параметры настройки сервиса могут быть не сохранены. Поэтому, если при уменьшении значения система становится нестабильной, рекомендуется попробовать увеличить это значение до тех пор, пока система не будет полностью стабильной.


Управление размером файла SHELLICONCACHE

Windows хранит некоторые значки, используемые оболочкой, в файле SHELLICONCACHE. При частом изменений параметров оболочки размер данного файла увеличивается, что приводит постепенно к тормозам при перерисовке значков из-за отсутствия места в кэше. Можно увеличть размер кэша этого файла, устанавливая строковый параметр Max Cached Icons в разделе
HKEY_LOCAL_MACHINE\Software\Microsoft\ Windows\CurrentVersion\Explorer
равным 5000 (5 Мбайт)

По умолчанию этот параметр не присутствует в реестре.

Рекомендуется иногда удалять файл SHELLICONCACHE, особенно, когда вы начинаете замечать, что значки становятся черными на Рабочем столе


Замена логотипа в Internet Explorer

Логотип по сути своей представляет собой вертикальную последовательность кадров-картинок в формате BMP-256. Таких лент должно быть две. В одной кадры должны быть 26х26 точек, в другой 38х38. Длина ленты (а стало быть и количество кадров) может быть любой длины. Важно лишь следить, чтобы длина ленты в одном случае была кратной 26 точкам, в другом - 38. Разместите оба файла в легкодоступном месте. Например в C:\WINDOWS\SYSTEM. Для примера назовем эти файлы bg_logo.bmp и sm_logo.bmp. Создайте ветвь (если не существует): HKEY_Current_User\Software\Microsoft\Internet Explorer\Toolbar и установите два параметра: BrandBitmap и SmBrandBitmap. BrandBitmap должен содержать путь к "большому" логотипу (в нашем случае C:\WINDOWS\SYSTEM\bg_logo.bmp). SmBrandBitmap - путь к "маленькому" логотипу ( C:\WINDOWS\SYSTEM\sm_logo.bmp).


Замена заголовка в Internet Explorer

Найдите или создайте следующий строковый параметр: HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\WindowTitle . Создайте новую строку или измените существующую запись на вашу. Удалив раздел WindowTitle, вы установите значение заголовка по умолчанию


Замена фона в панели инструментов в Internet Explorer

Существует возможность установки своего фона для панели инструментов в Internet Explorer. Для этого в разделе реестра HKEY_CURRENT_USER \SOFTWARE\ Microsoft\Internet Explorer\Toolbar создайте строковый параметр BackBitmap, значением которого будет полное имя BMP-файла с нужной картинкой - она и замостится мозаикой на панелях окон. Кстати, заодно замостится и панель инструментов Проводника.

Для замены фона только в Проводнике, не затрагивая Internet Explorer смотрите Замена фона в панели инструментов в Проводнике


Установка стартовой странички

Найдите или создайте следующий строковый параметр: HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\Start Page. Создайте новую строку или измените существующую запись на вашу. Удалив раздел Start Page, вы установите значение по умолчанию

Теперь, при запуске браузера будет загружаться указанная страница


Контекстное меню в Internet Explorer

Если контекстное меню вашего браузера, выпадающего, если нажать правую кнопку мыши на ссылке, содержит слишком много лишних команд, то найдите раздел: HKEY_CURRENT_USER\ SOFTWARE\Microsoft\ Internet Explorer\MenuExt. Данный раздел содержит подразделы, которые вы можете удалять, изменять, редактировать


Кнопки на панели инструментов в Internet Explorer

Если панель инструментов вашего браузера содержит слишком много лишних кнопок, то найдите раздел: HKEY_LOCAL_MACHINE\ Software\ Microsoft\Internet Explorer\ Extensions. Данный раздел содержит подразделы, которые вы можете удалять, изменять, редактировать

Лишние кнопки могут быть невидимы, но присутствовать на панели инструментов. Чтобы просмотреть все существующие кнопки, нажмите правой кнопкой на панели инструментов и выберите команду Настройка


Строчки для комбобокса Адрес

При нажатии на треугольник в комбобоксе Адрес вываливается список вводимых вами адресов.

Вы можете отредактировать этот список (добавить, удалить, изменить). Войдите в раздел: HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\TypedURLs. Там присутствует список ваших адресов, начиная со строкового параметра url1. Добавляйте или удаляйте строки, но следите, чтобы параметры были упорядоченными. Иначе, если у вас будет url1, url2, url5, url6, то будут выводиться только первые два адреса

Примечание: Данный список будет появляться, если в комбобоксе находится веб-адрес. Если же там путь к файлу на локальном компьютере, то появится список, аналогичный списку Проводника


Панель инструментов изображений

Панель инструментов изображений (Internet Explorer 5.5 и выше)

В Internet Explorer при наведении указателя мыши на рисунок, который требуется сохранить, в уголке рисунка появляется панель инструментов изображений.

Эта панель позволяет быстро осуществить разные операции: сохранить, печатать, послать по почте, открыть папку Мои рисунки

Для отключения данной панели инструментов изображений создайте ключ типа DWORD MyPics_Hoverbar в разделе
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\PhotoSupport со значением 1

Для включения панели инструментов изображений удалите описанный параметр или присвойте ему значение 0

Примечание: Панель инструментов изображений появляется не для всех рисунков. Для использования панели инструментов размер рисунка должен быть не менее 200 x 200 пикселов


Замена заголовка в Outlook Express

Для Outlook Express 4
Найдите или создайте следующий строковый параметр: HKEY_CURRENT_USER\Software\Microsoft\Outlook Express\WindowTitle. Создайте новую строку или измените существующую запись на вашу. Удалив раздел WindowTitle, вы установите значение заголовка по умолчанию

Для Outlook Express 5.0 и 6.0
Для Outlook Express 5.0 и 6.0 местоположение ключа изменилось на: HKEY_CURRENT_USER\Identities\{** Identity ID **}\Software\Microsoft\Outlook Express\5.0\WindowTitle, где {** Identity ID **} - ваш идентификатор


Удаление заставки в Outlook Express

Для Outlook Express 4
Найдите или создайте следующий параметр DWORD: HKEY_CURRENT_USER\Software\Microsoft\Outlook Express\NoSplash. Если установите значение параметра равным 1, то заставка появляться не будет. Для появления заставки во время загрузки Outlook Express установите значение параметра в 0

Для Outlook Express 5.0 и 6.0
Для Outlook Express 5.0 и 6.0 местоположение ключа изменилось на: HKEY_CURRENT_USER\Identities\{** Identity ID **}\Software\Microsoft\Outlook Express\5.0\NoSplash, где {** Identity ID **} - ваш идентификатор


Общая Адресная книга

Общая Адресная книга в Outlook Express

Если нужно, чтобы несколько пользователей одного компьютера пользовались общей адресной книгой в Outlook Express, то проделайте следующее:
Войдите в систему под именем первого пользователя, запустите редактор реестра и найдите ключ
HKEY CURRENT USER\Software\Microsoft\WAB\WAB4\Wab File Name, в котором найдите путь к wab-файлу.
Теперь войдите под именем другого пользователя, найдите тот же ключ и впишите тот же путь к wab-файлу. Повторите ту же процедуру для всех пользователей. Теперь адресная книга у всех будет одна.


Изменение заголовка в Windows Media Player

Для изменения заголовка в Windows Media Player откройте или создайте раздел HKEY_CURRENT_USER\Software\Policies\Microsoft\WindowsMediaPlayer с строковым параметром TitleBar, содержащим ваш текст


Ошибки в Office

Ошибки в Office (Office XP)

При возникновении сбоя в Office XP утилита DW.exe пытается отправить отчет о нем в Microsoft. Если вы не хотите заниматься ловлей багов, то можете отключить эту функцию. Существует несколько различных параметров, находящихся в разделе
HKEY_CURRENT_USER\Software\Policies\ Microsoft\Office\10.0\Common

  • Параметр типа DWORD DWNeverUpload со значением 1 отключает отправку данных и не выводит соответствущее сообщение
  • Параметр типа DWORD DWNoExternalURL со значением 1 отключает соединение с сервером Майкрософт и не выводит соответствущее сообщение
  • Параметр типа DWORD DWNoFileCollection со значением 1 не высылает файлы, запрашиваемые сервером обработки ошибок
  • Параметр типа DWORD DWNoSecondLevelCollection со значением 1 не высылает файлы особого рода (записи в реестре, версия файлов, используемые программы), запрашиваемые сервером обработки ошибок

Отсутствие этих параметров (по умолчанию) или установка в 0 включает эти настройки обратно


Выбираем персонаж

Выбираем персонаж (Office XP)

Можно подключать собственных персонажей к приложениям Office. Для этого перейдите в раздел
HKEY_CURRENT_USER\Software\Microsoft\Office\Common\Assistant и создайте строковый параметр AsstFile, в котором пропишите полный путь к вашему acs-файлу персонажа

Этот способ удобен, если ваш персонаж находится не в стандартной папке персонажей, который сканируется Office для выбора нового персонажа. Например, таким образом вы можете подключить персонаж Magic Gooddy, который находится в своей папке


Visual Basic 6.0

В Visual Basic 6.0 в отличие от пятой версии окна Code и Object появляются в нормальном, не в раскрытом виде. И приходится при каждом запуске VB6 раскрывать эти окна. Можно заставить автоматически раскрывать эти окна при каждом запуске. Создайте в соответствующем разделе реестра
HKEY_CURRENT_USER/Software/Microsoft/Visual Basic/6.0 строковый параметр MDIMaximized = "1"


RegClean 4.1

RegClean 4.1a

RegClean - это утилита от Майкрософт для работы с реестром. Рекомендуется для содержания реестра в надлежащем порядке

Что делает RegClean?

RegClean анализирует ключи реестра, расположенные в разделе HKEY_CLASSES_ROOT и находит ключи, содержащие ошибочные значения. RegClean записывает эти значения в файл Undo*.reg, имеющий следующий формат - после Undo записывается имя компьютера, дата и время:
Undo SASHA 20020721 110917.Reg
Затем RegClean удаляет ошибочные записи из реестра

Что RegClean не делает?

RegClean не является универсальной программой для лечения и восстановления реестра и не способна находить и исправлять ошибки в других разделах

Где скачать?

Скачать программу можно по адресу http://winchanger.narod.ru/regclean.zip

Как пользоваться RegClean?

Запустите RegClean (regclean.exe). RegClean выводит окно с индикатором прогресса. В это время программа сканирует реестр. В зависимости от размера вашего реестра и мощности компьютера сканирование может занять от 30 секунд до 30 минут.

После окончания сканирования индикатор прогресса исчезнет и вам будет предложено два варианта для продолжения:

Закончить работу RegClean - если вы не хотите очистить реестр и сохранить найденные ошибки, то выбирайте кнопку Cancel

Зафиксировать ошибки - если вы хотите очистить реестр от ошибок и сохранить найденные ошибки, то жмите на кнопку Fix Errors. Через несколько секунд программа запишет найденные ошибки в файл, который находится в той же папке, где установлена ваша программа RegClean. После этого вы можете закрыть программу, нажав кнопку Exit.

Если в течение нескольких дней ваша система работает стабильно, вы можете удалить созданный файл. Если в вашем компьютере стали возникать ошибки, и вы думаете, что это произошло из-за удаленных записей реестра, то можете восстановить прежние параметры, щелкнув два раза на сохраненном файле Undo.reg


RegShot

RegShot - маленькая утилита, позволяющая быстро сделать снимки рееста и сравнить их. Все изменения в реестре можно сохранить в файле. Удобно, если вы хотите знать, какие изменения в реестр вносить новая программа при инсталяции

Где скачать?

Скачать программу можно по адресу http://winchanger.narod.ru/regshot161d.zip

Как пользоваться RegShot?

Порядок работы с программой читайте в файле readme.txt


Благодарности

Признательность

При составление справочника автором справочника А.Климовым использовались самые разные источники: интернет, книги, журнальные и газетные публикации

Отдельное спасибо хочется сказать следующим людям, помогавшим мне в работе над справочником

  • Евгений Соболев (SOFTODROM) - за дельные замечания
  • Александр Пыльчагин (http://poirot.h1.ru/) - присылающему очень много материалов